Забыли пароль?

Установка FastReport 4 для Lazarus

Den Zubov

Не так давно мы добавили поддержку среды Lazarus для FastReport 4 (начиная с Pro редакции, потому что Lazarus часто обновляется и требует перекомпиляции из исходных кодов).
Так как продукт все еще в стадии беты, нет никакой подробной инструкции по его установке. Эта базовая статья покажет, как можно установить FastReport 4 под lazarus и раскроет некоторые особенности.

Для начала вам понадобится инсталлятор FastReport 4 VCL (начиная с Pro версии, можно использовать установку только исходных кодов. Или попробовать триальную версию собраную под Lazarus 1.0.8), а так же установленный Lazarus IDE (с FPC). После чего, можно начинать установку пакетов FastReport 4.

Начнем с платформы Win32:
Запустите  Lazarus IDE (под win32 FastReport работает со стандартным набором виджетов и не требует перекомпиляции).

В Lazarus IDE откройте "Пакет" -> "Открыть файл пакета(*.lpk)".

Installing packages 

Теперь нужно найти и установить пакеты  FastScript (fs_lazarus.lpk). Если FastReport 4 VCL был установлен с использованием путей по умолчанию, то пакет можно найти по данному пути "C:\Program Files\FastReports\FastReport 4\FastScript".

Тут стоит отметить, что наш установщик работает с правами администратора и после установки следует проверить права доступа у каталога "Fast Report 4" и добавть доступ на запись для текущего пользователя, иначе пакет может не скомпилироваться.

Откройте пакет fs_lazarus.lpk  и выберите  "Использовать" -> "Установить". Lazarus должен собрать себя с использованием нового пакета.

Componet pallate 

После установки пакета FastScript нужно найти и установить пакет FastReport 4 (fr4_lazarus.lpk). Если FastReport 4 VCL был установлен с использованием путей по умолчанию, то пакет можно найти по данному пути "C:\Program Files\FastReports\FastReport 4\Source".

Откройте пакет fr4_lazarus.lpk и выберете "Использовать" -> "Установить". Lazarus должен собрать себя с использованием нового пакета.

Замечание: После компиляции lazarus может не запуститься и требовать библиотеку zlib1.dll. Это происходит потому, что  FastReport 4 использует библиотеку Zlib. Чтобы исправить эту ошибку, необходимо скачать библиотеку Zlib1.dll в каталог, где находится Lazarus.exe. 

 Теперь можно использовать FastReport 4 в lazarus практически идентично VCL версии.

Designer 

Установка под linux: 

Установка FastReport 4 для Lazarus под linux (убедитесь, что используете хотя бы  4.14.3 версию для компиляции под Linux!) практически идентична установке для windows. Для начала нужно скопировать директории "FastReport4\Source" и  "FastReport4\Fast Script" в ОС linux на которой будет осуществляться компиляция.

Следующим шагом будет перекомпиляция lazarus с набором виджетов Qt (по умолчанию используется  gtk), на данный момент  FastReport 4 работает только с Qt. Запустите Lazarus IDE, зайдите в меню "Сервис" -> "Параметры сборки Lazarus .." и выберите для "Библиотека виджетов LCL" -> "Qt". Нажмите собрать (Библиотека Qt должна быть установлена в вашей системе).

Laz Widgets 

 Lazarus about

После компиляции Lazarus готов к установке пакетов  FastReport.  Запустите Lazarus IDE и откройте меню "Пакет" -> "Открыть файл пакета (*.lpk)". Найдите и установите пакеты Fast Script(fs_lazarus.lpk)  и FastReport 4 (fr4_lazarus.lpk).

Теперь FastReport 4 готов для работы в linux !

Fast Report 4 linux 

Данный продукт все еще находится в стадии беты и некоторый функционал может быть недоступен. На данный момент отсутствуют фильтры экспортов, но мы планируем добавить их в будущем. Также св-во TfrxMemoView.Font.Charset должно быть всегда установлено в DEFAULT_CHARSET, т.к. на данный момент нет реализации кодировок.

Похожие статьи:

назад

Комментарии

Stephane WIERZBICKI
2166 дней назад
Excellent post ! I'm using Lazarus 1.10 and I was able to compile and install all packages (be sure to compile the package with the default OS/CPU configuration) I'm looking forward for updated fast-report version :) Thank you